User Tag List

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-24-2007, 10:51 PM
Board Regular
Thread Starter
Join Date: Aug 2006
Location: Somewhere in the Western 11
Posts: 265
Default Engine brake problems...

As of late my truck has been having some major problems with the engine brake. I have a 2005 Peterbilt 379 with around 300k miles on it and it has a Cummins ISX (EGR equipped).

When I am going down long and steep grades, the brake will come on but only under a minimal setting regardless of the actual position of the "C" brake setting. After continuing to accelerate down the hill, it will then kick up to medium or high.

This is very prevalent going down grades in Nevada, California, and Oregon (I am a western 11 driver). When it tries to engage the medium or high setting, it will make a lot of noise (can't describe) and it then feels like the engine is unbalanced. After cycling the engine brake, it will then start to actually work correctly.

It is currently in the shop at Cummins and they are having one heck of a time trying to get this figured out. Any ideas?

Thanks in advance.
__________________
I used to drive a Volvo 770, and I broke it. I used to drive a Volvo 780 and I broke it. I now drive a Peterbilt 379 and am trying not to break it
Reply With Quote
Reply






Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 06:37 AM.


User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.