User Tag List

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-30-2008, 07:20 PM
Member
Thread Starter
Join Date: Aug 2007
Posts: 72
Default Water pump on Cat C-12.

I have an 1999 International 9200i with a Cat C-12 and the water pump is leaking antifrezze in the oil. Does anyone know if a normal schmuck like me can tackle a job like this and is there a good online store I can purchase the water pump? Thanks for your help!!
__________________
No God, No Life: Know God, Know Life
Reply With Quote
  #2  
Old 10-30-2008, 09:03 PM
Member
Thread Starter
Join Date: Aug 2007
Posts: 72
Default

I just got a call back from the dealer and they said $375. Is that a good price?
__________________
No God, No Life: Know God, Know Life
Reply With Quote
  #3  
Old 10-30-2008, 11:16 PM
bob h's Avatar
Senior Board Member
Join Date: Oct 2006
Location: Nb
Posts: 794
Default

Quote:
Originally Posted by 4GIVEN View Post
I have an 1999 International 9200i with a Cat C-12 and the water pump is leaking antifrezze in the oil. Does anyone know if a normal schmuck like me can tackle a job like this and is there a good online store I can purchase the water pump? Thanks for your help!!

How did you verify that the water pump is the cause of 'water in the base'?
__________________
Bob H
Reply With Quote
  #4  
Old 10-31-2008, 12:47 AM
Member
Thread Starter
Join Date: Aug 2007
Posts: 72
Default

Well, I had an oil change done and I noticed that my coolant was a little low and I had the oil tested at my local cat dealer and it came back positive for coolant. The guy there told me that the water pump was the main culprit for the coolant in the oil. My engine was just overhauled about 30k ago. I was just starting with the water pump.
__________________
No God, No Life: Know God, Know Life
Reply With Quote
  #5  
Old 11-01-2008, 01:38 PM
bob h's Avatar
Senior Board Member
Join Date: Oct 2006
Location: Nb
Posts: 794
Default

Quote:
Originally Posted by 4GIVEN View Post
Well, I had an oil change done and I noticed that my coolant was a little low and I had the oil tested at my local cat dealer and it came back positive for coolant. The guy there told me that the water pump was the main culprit for the coolant in the oil. My engine was just overhauled about 30k ago. I was just starting with the water pump.

I can't remember specifically with the c12, because i haven't worked on a lot of them... but, in 99.9% of cooling system water pumps, there is an airspace between the cooling system and the crankcase where a weep hole will leak coolant 'on it's way' to the oil side of the engine.

Therefore... it has to pass through; the coolant side seal, then across an open airspace (where it should leak out onto the ground), and then through the oil seal on the opposite side of the weep hole area.

...not a typical failure. Unless the weep hole is plugged, or there is some sort of flaw in that coolant pump mounting that i'm not aware of as a problem, which is also possible ; )
__________________
Bob H
Reply With Quote
  #6  
Old 11-19-2008, 03:26 PM
Member
Thread Starter
Join Date: Aug 2007
Posts: 72
Default

Well I changed the water pump and all is good. I havent used any coolant since. That water pump had about 680k on it, so I guess it needed it. Im going to wait a little bit and have the oil tested again. Thanks for everyones response.
__________________
No God, No Life: Know God, Know Life
Reply With Quote
Reply






Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:04 PM.


User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.